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Electronic data collection and transmission

for locust field officers

All comments and suggestions for improvements are welcome and very much
appreciated. Please send these as well as any questions or problems to

keith.cressman@fao.org.
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1 Introduction

(a) The current system

Some locust affected countries such as Mauritania, Sudan, Saudi Arabia, Pakistan and
India collect large amounts of locust and habitat data in the field during surveys. These
countries not only have regular survey programmes in most months of any given year but
they are also prone to Desert Locust infestations during at least one breeding season per
year. The standard method of data collection, transmission and analysis is for a national
locust unit to undertake field surveys in the desert using 4WD vehicles. The national
locust survey officers make up to about a dozen stops in a single day, checking
vegetation and soil moisture, looking for locusts and interviewing people along the way
such as nomads, travelers, villagers and farmers. They generally record their observations
in a survey notebook and often use a standard form developed in conjunction with the
countries by FAO. This helps to standardize data as well as collection methodologies to
allow data sharing and analysis between countries. The data is used for planning at the
national level and forecasting and keeping countries informed at the international level.

The data collected by the survey officer is sent to a national locust centre, usually in the
capital city of each affected country. There, a designated individual, the national locust
information officer, is responsible for collating, processing and analysing the data. He/she
should forward the data to the Desert Locust Information Service (DLIS) at FAO
Headquarters in Rome, including a brief interpretation of what the data means. Data from
the field to the national locust centre is sent by radio or hand carried. Data arrives at DLIS
by fax or email. Great efforts are made to transmit the data quickly and completely since
its value degenerates rapidly over time.
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(b) The problem

In those countries with regular survey programmes, the large quantity of data collected in
the field by the national survey officers cannot be sent by radio to the national locust unit
headquarters. It simply takes too much time to transmit each piece of information verbally
through a single radio channel. It is very common for data to become corrupted during
transmission when the recipient cannot clearly hear the caller. Data also becomes
corrupted when it is written down at the recipient's end or when it is sent to DLIS. Hence,
there are serious problems with the quantity, quality and transmission of the data from the
field. As a result, the survey officer either has to summarize the data prior to transmission,
send the data by post or hand carry it which may involve significant delays making it is
less useful for planning or forecasting, or limit the number of survey stops in a day.

There is a lot of interest by donors, affected countries and FAO to have more accurate
information and precise forecasts in near real time. This means improving the system of
data collection, transmission and analysis which forms the backbone of the early warning
plague prevention strategy for Desert Locust. In order to meet this request, the weak links
in the system must be strengthened. These are primarily data transmission and
management that becomes even more important during situations when there are large
volumes of data that must sent and analysed.

(c) A potential solution

A new system, called eLocust, is under development that addresses these very issues. It
is modelled on a similar system in operation by the Australian Plague Locust Commission
in their own country. The objective is threefold: to improve data collection by the survey
officer in the field, to improve data transmission, to improve data management by the
locust information officer at the national locust unit headquarters.

eLocust allows the locust field officer to enter observations and data directly into a
database while in the field at each survey or control location and view data on a map. For
this, a Psion palmtop computer (hereafter referred to as S5), preferably the 5mx series, a
GPS (preferably Garmin 12XL), a cigarette lighter Psion-GPS power/data cable, and
shareware software (PsiDat, eLocust, RealMaps) are required. All equipment can be used
on batteries as well as using the vehicle's power. Two AA batteries power the S5 for
approximately 40 hours.

(d) Daily use in the field

eLocust should be used during survey and control operations. Once the field officer
arrives at a location, the date, time and coordinates are automatically entered into
eLocust via the GPS. The field officer then gets out of the vehicle and collects the
necessary data in the field. Back inside the vehicle, this data is entered into eLocust
before moving to the next location. There are three methods in which to use the above
equipment:

1. Connect the S5 to the GPS and plug both into the cigarette lighter of the
survey/control vehicle using a special power/data cable, turn them on and keep
them on during the entire survey. In this way, the route and stops of the survey
can be viewed on a series of maps on the S5, and the GPS coordinates of each
stop are automatically entered into eLocust. Custom maps, satellite images,
greenness maps, and locust frequency maps, can be made within RAMSES or
SWARMS.

2. Connect the S5 to the GPS and turn both of these on only at the survey stop.
Once you have completed entering your observations and data into eLocust, the
equipment is turned off until the next survey stop. Although this may allow
batteries to last longer, you will lose the benefit of following the progress of the
survey on a map.

3. A hybrid of the first two methods. Simply follow the first procedure but only turn on
the S5 occasionally along the survey route to see where you are and to turn it on
at each stop. This may be the most practical when off-road, in difficult terrain and
dusty conditions.
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At any time, it is possible to view the survey route, the current location, or any aspect of
the data entered into the S5 on a series of maps. These are displayed as overlays in
RealMaps. You can have RealMaps and eLocust open at the same time and easily switch
between the two.

The information stored in eLocust can be uploaded to a PC upon returning to the office
(for sending by email to FAO), transferred to another S5, or transmitted by HF radio
modem from the field to a computer in the national locust centre. The latter is currently
being tested and improved. The data can also be incorporated into the RAMSES and
SWARMS GIS applications for analysis and forecasting at the national and international
levels respectively.

It is anticipated that eLocust will be most useful for those countries where large quantities
of data are regularly collected in the field and need to be evaluated and analysed for
decision-making purposes and for early warning and forecasting. It is hoped that the use
of eLocust will lead to better quality and more complete field data as well as to reduce the
difficulty in managing large volumes of data at the national and international levels.

2 Features

(a) Basic functions

With the S5 connected to the GPS, turn both units on. Make a copy of the eLocust file
(Ctrl-C, Ctrl-V) and rename it (Ctrl-R) to EEYYMMDD where EE is the team number or
identification, YY is year, MM is month, DD is day. Open the renamed eLocust file. You
will immediately be asked to enter your identification (your initials or team number). Then
you will see the data fields of the basic information to be collected at each survey and
control location. Start with date and end with comments. Move from field to the field with
the pen and the up/down, page up/page down keys, or the vertical scroll bar. You can
also move directly to each section (press '.' then right/left arrow keys). Many fields have a
built-in pop-up menu that appears when you tap on the field, allowing you to make a
selection rather than typing in long strings of text. Other fields are free-format in which you
can enter anything including approximate rain dates. Solitary adult densities are
determined by entering the transect length and width, and the number of adults seen; the
density is then automatically calculated for the area of the transect. Entries are
automatically saved. When you have finished entering data, tap Add on the menu on the
right-hand side. This will bring up a new blank record ready for the next stop.
Observations made enroute can also be recorded using the same procedure. Help is
built-in (About Menu).

(b) Entering GPS coordinates

Make sure the GPS is connected to the S5 and both are turned on. Check to insure the
Interface setting is NMEA/NMEA and baud rate is 4800 (Setup page on the GPS). Once
the current position is displayed on the GPS, switch to RealMaps on the S5 (Shift-K from
eLocust). Turn on GPS Moving Map (Special Menu or Ctrl-G). A window will appear. Press
OK. After a few seconds, a small window will appear on the left or right side of the screen
with some information. The cursor will become a triangle indicating your current position
and direction of travel. You can now stop GPS Moving Map by pressing ESC. Go to
eLocust (Shift-K) and tap once in the latitude and longitude fields. This will transfer the
current coordinates from the GPS and RealMaps to eLocust.

If you don't have a GPS, you can tap a location on the map in RealMaps and press the
<Enter> key to mark a 'Jump To' location. You can load this position into eLocust by
tapping on the latitude and longitude fields. However, this will not be as accurate as using
a GPS.

You can also enter GPS coordinates manually. Place the cursor on the Name field and
use the down-arrow to move to Latitude. Enter the degrees, then a space, the minutes,
then a space and the seconds, then <Enter> key (e.g. 22 34 51). Place the cursor on the
Area field and use the up-arrow to move to Longitude field. If longitude is West, type a
minus (-) before the degrees.There is no need to type N, S, E or W.
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(c) Data entry and navigation

Most data is entered by making selections from lists. In general, use the pen to tap once
inside the field that you want to enter data. If there is a list to chose from, it will pop up.
Tap once on your selection and then a second time to enter it into the field. In some
cases, the name of the field will remain highlighted. This indicates that additional
information may be entered such as a numbers of locusts or mm of rainfall. If you do not
want to enter any numbers, press <Enter> or tap in the next field you want to enter data.
In other cases, you can also select a blank from the pop-up list. This will delete any data
in the field, leaving it blank. The data for the Date, Latitude and Longitude fields come
from the GPS. Simply tap on these fields. In the comments fields, you can type anything
and then press Save. In the Habitat field, you can type in other words that are not on the
list. You will be asked if you want to add this to your Lookups. If you answer Yes, it will be
added to the pop-up list to use next time. To view the first line of the comments, select
Options/General: Show Comments Text.

To move up or down within a record, use the PgUp or PgDn keys, the up- and down-
arrow keys, or the scroll bar on the right (this is turned  on in View Menu: Show
Scrollbars). You can also press '.' then select the beginning of a section to jump to with
the right/left arrow key. To move between records, use the right- and left-arrow keys. You
can also use the Record Menu, or the buttons on the right side of the screen (these are
turned on in View Menu: Show Toolbars). To show the record number, go to View Menu:
Show Record Info.

(d) Viewing survey stops on RealMaps

From the Options Menu, select Show Location to view the location of the record displayed
(this may not be your current position!) on RealMaps, Show Data to view selected data.
The data to view is selected in the Show1 and Show2 fields in the window that appears.
If you chose <nothing> for both fields, then only the record number will be displayed at
each location. Also in the window that appears, you can save your selection by changing
the file name. This is useful if you want to view these overlays at some later time. In both
cases, a second window will appear where you can vary the line width and text display.
Note that in RealMaps, each time you zoom in or out, you will need to reload your
selection either by going back to eLocust and repeating the above procedure, or if you
saved the overlay, go to the Add Menu in RealMaps and select Overlay (TXT), indicating
the saved file.

For advanced users, there is an alternative method. Connect GPS to S5 and use PsiGar
to save waypoints to S5, export as RealMaps text.. Open RealMaps and select Add
Menu: Overlay txt file, turn show text off to see just points, increase lines for thicker
points. Note: You must have a registered version of PsiGar installed on your S5 for this to
work.

(e) Data export

eLocust data can be exported in several different formats available in the File Menu. The
Standard eLocust Format is for RAMSES. The other formats are in the Export submenu.
The text format is probably the most common and useful for importing into a variety of PC
applications such as Word and Excel. The HTML option will export the data as HTML
format which can be placed on the Internet or easily shared with others. HTML files are
viewed by any web browser application (e.g. Netscape, Explorer, Opera). In the More
options of the different formats, you can select which fields to export.

You can also copy all of the data of eLocust and paste into Excel using the Edit Menu:
Copy all records. If you want to include the field names, select this in Edit Menu: Clip
Options.

(f) Languages

eLocust is available in English and French. You can switch between the two languages in
the About Menu. Make sure that the French module has been installed.
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3 Feature developments

• Customization of eLocust to meet the needs of individual countries. So far, this has
only been requested by Mauritania (called eLocust MAU).

• With the discontinuation of the production of Psion 5mx equipment, alternative
platforms for eLocust will need to be identified that do not compromise the current
software and hardware features of eLocust. One potential solution would be
revamping eLocust to operate under ArcPad on a Palm handheld device. It is
hoped that this and other possibilities will be investigated by EMPRES in
collaboration with DLIS.

4 Approximate cost of eLocust

Codan Base station US$4750
Codan mobile station US$4850
Psion 5MX handheld computer (*) US$550
Garmin 12XL GPS US$200

(*) includes case, additional 16mb disk, GPS/Psion/cigarette lighter cable

Prices as of autumn, 2003

5 Software updates and file management

(a) updates

The latest version and all updates of RealMaps, PsiDat, eLocust and other relevant
documents are available on the DLIS webpage where they can be downloaded to the PC
and installed onto the Psion:

www.fao.org/news/global/locusts/eldown.htm

Although DLIS will inform you of new versions of the software used for eLocust, it is
suggested that you check this site on a regular basis.

(b) file management

DLIS prepares the Psion and installs the necessary files on it before it is sent to a locust-
affected country. In most cases, the Psion has two hard drives (C and D) of 16 mb each.
This is more than sufficient to contain all the necessary files and allow enough space for
new ones.

The C drive, called “internal”, contains three directories (called folders on the Psion):
Documents, psiGar, System. In order to see the System file, you must select Show hidden
files and Show ‘System’ folder (Tools Menu: Preferences). Normally, there is no need to
work on C. Instead, all of your working documents will be saved on D, called
“<countryname>1” (e.g. Oman1). On the D drive are four folders: documents, eLocust,
installers, and maps.

• Documents – currently empty; this is where you can save all of your files, creating
subfolders inside the Documents folder as you require
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• eLocust – all of the files needed for eLocust and where you would save survey
results:

eLocust.HLP -> the help file for eLocust

eLocust109 -> the current version of eLocust; you should always have a
blank copy of this file

docs subfolder -> contains files descibing eLocust, Codan HF modem
transfer, PsiGar and the Psion:

codan4elocust -> use of Codan and eLocust

codantransmit -> HF radio modem transmission

eLocust manual -> user’s manual

eLocust field guide -> field guide for locust officers

eLocust-data.htm -> data structure of eLocust

make map -> how to make maps for RealMaps

psigar manual -> user’s manual

using this psion -> tips on using the Psion

• installers – instalation files for various applications. These can be transferred to
other Psions via Infrared in order to install applications. They can also be used in
case you need to reinstall any application on your Psion. Caution: the .sis
instalation file will be automatically deleted when instalation is completed;
therefore, make a copy of the .sis file before installing. Install by double-clicking
the file.

Defrag5 -> defragment utility for the hard disk

PsiGar -> GPS data management application

RealMaps -> map application (NB: after installing RealMaps, copy
maplist, realmaps.reg, worldcities.s5 files to
c:/system/apps/realmaps, and move all the files and folders in
c:/documents/maps to d:/maps, then delete
c:/documents/maps folder)

Cleanitc.sis -> removes unused files

Converter.sis -> weights and measures conversion application

eLocust.HLP -> eLocust help file

eLocust109 -> latest version of eLocust

pdf.sis -> PDF reader application

PsiDat -> database application (required for eLocust)

• Maps – contains the maps and overlays for RealMaps. There are several maps
that are automatically installed with RealMaps (but in c:/documents/maps, see
note above). Custom maps (with file extension .mbm) vary by country and are
provided by DLIS. Additional place names can be added to custom maps by
entering their name and coordinates in c:\system\apps\realmaps\worldcities.s5.
You should follow the specific format (decimal degrees) of the file.

Please see the Using this Psion and eLocust Field Guide files on the Psion for more tricks
and tips on file management and further customization of the Psion.


