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   PREFACE   

The Research for the Management of the Fisheries on Lake
Tanganyika project (LTR) became fully operational in January
1992. It is executed by the Food and Agriculture Organization of
the United Nations (FAO) and funded by the Finnish International
Development Agency (FINNIDA).

LTR’s objective is the determination of the biological basis
for fish production on Lake Tanganyika, in order to permit the
formulation of a coherent lake-wide fisheries management policy
for the four riparian States (Burundi, Tanzania, Zaïre and
Zambia)

Particular attention is given to the reinforcement of the
skills and physical facilities of the fisheries research units
in all four beneficiary countries as well as to the buildup of
effective coordination mechanisms to ensure full collaboration
between the Governments concerned.

Prof. O.V. LINDQVIST Dr. George HANEK
LTR Scientific Coordinator LTR Coordinator

LAKE TANGANYIKA RESEARCH (LTR)
FAO

B.P. 1250
BUJUMBURA
BURUNDI

Telex: FOODAGRI BDI 5092 Tel.: (257) 22 97 60

Fax.: (257) 22 97 61
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   GCP/RAF/271/FIN PUBLICATIONS   

Publications of the project are issued in two series:

* a series of technical documents (GCP/RAF/271/FIN-TD) related
to meetings, missions and research organized by the project; and

* a series of manuals and field guides (GCP/RAF/271/FIN-FM)
related to training and field work activities conducted in the
framework of the project.

For both series, reference is further made to the document
number (01), and the language in which the document is issued:
English (En) and/or French (Fr).

   For bibliographic purposes this document   
   should be cited as follows   :

Peltonen, A. Operation manual for Aaderaa software.
1994 FAO/FINNIDA Research for the Management of the 

Fisheries on Lake Tanganyika.
 GCP/RAF/271/FIN-FM/14 (En): 13p.

Ms. Anu Peltonen is a member of the LTR Scientific Team
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1 INTRODUCTION

This new Aanderaa-software has been developed to unload the
data from the Aanderaa instruments, e.g., weather stations and
thermistor strings. It is easy to use and it includes also data
analysis. All the information is saved into five databases:

1. Projects database
2. Devices database
3. Sensors database
4. Measurements parameters
5. Current sensors

Once you have written all the information to the databases
1-3 you only have to change them when a sensor is changed or a
new device is installed. Every time a Data Storage Unit (DSU) is
read you have to add new information to databases 4 and 5.

2 GETTING STARTED

2.1 Installation

Obs.! All the files should be copied to the drive c: .

Create Aanderaa-directory to the drive c: with command md
aanderaa and copy there all the files from the disk1 with command
copy a: \*.* c:\aanderaa. The *.dll should also be copied to
windows-directory and bwcc.dll also to the root-directory.

Create Pdoxwin-directory to the drive c: by writing md pdoxwin
and move into that directory by writing cd pdoxwin. Create a
Private-subdirectory to the c:\pdoxwin-directory with command md
private and copy there all the files from the disk2 with command
copy a:\*.* c:\pdoxwin\private.

When you have created all the directories and copied all the
files add the following lines to the Win.ini -file after the
[fonts]-option:

[Paradox Engine]
UserName=PxEngine
NetNamePath=C:\PDOXWIN\PRIVATE
NetType=2
ShareLocal=YES
PX35Locking=NO
MaxTables=60
RecBufs=200
MaxLocks=64
MaxFiles=100
SwapSize=256
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Add following lines to your autoexec.bat -file and reboot your
computer (check that these files are in the C:\DOS-directory):

c:\dos\smartdrv.exe c+
c:\dos\share.exe

Start Windows and choose File -> New. Choose Program group from
the New Program Object-window and click OK. Now you get a new
window. Write to the line Description Aanderaa and click OK.

Choose the Aanderaa-window and click File -> New. Choose Program
from the New Program Object-window and click OK. Now there is
another new window open. Add there the following lines:

Description: Aanderaa
Command line: c:\aanderaa\dinput.exe
Working directory:  c:\aanderaa

and click OK.

Obs.! If you have a Paradox for Windows-program in your computer,
start from the Paradox-group window Configuration Utility -
program by double clicking its icon. Check that your Network
Control File Directory is C:\PDOXWIN\PRIVATE and your Local Share
is On.

You can start the program by double clicking the Aanderaa icon.

2.2 Unloading the data storing unit

Unloading is done as told in the project's field manual
(Kotilainen, 1994). Connect the DSU-reader into the data storage
unit (DSU) as well as your computer's COM1 port. Plug cable no.
2842C from DSU-reader into the DSU, cable no. 3016A with the
extension into your computer's port and power cable for DSU-
reader. Open the Communications-window by clicking Window ->
Communications. Choose then Input -> From DSU and after that,
choose DSU commands -> Reset DSU.

Obs.! If you want to change the communication parameters choose
Communications-window and choose the right parameters with the
mouse.

Choose Input -> Start and the program unloads the data storing
unit. Unloading will stop automatically. Check that the numbers
are diminishing in the DSU display. If you want to interrupt data
unloading choose Input -> Stop. (to unload a full DSU takes about
50 minutes!). If you choose Input -> Log to a file before you
start unloading program will make a similar file as your raw data
file. You can turn the logging off by choosing Input -> Turn
logging off and delete logfile by choosing Input -> Clear log
file.

If you want to erase DSU, choose DSU commands -> Erase DSU.
This is not recommendable until you have checked that the data is
OK. You can also test DSU by choosing DSU commands -> Run DSU
internal test and check that the time is right by choosing DSU
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commands -> Change and display DSU real time clock.

After the DSU is unloaded choose Raw data editor -window by
clicking Window ->    4    RAW data editor. Check that the cursor is at
the beginning of the file and delete all the time information by
clicking Edit -> Delete time information. When this is done, the
program will show you the number of deleted lines with time
information. After that you can check possible errors in the data
by choosing Find -> Find next error. Commands mark data and Clear
marks are not in function.

The cursor will stop to the point where there is an error
and you have to do the corrections manually. If the cursor stops
at the end of file it means that there is an empty line and it
must be removed. You can delete a line by choosing Edit -> Delete
line.

2.3 Reading the ASCII-file

If you have already unloaded the data you can read the
ASCII-files into the program. Open Raw data editor -window by
choosing Window ->    4    Raw data editor. Choose File -> Load from
ASCII file. You will see a window where you can select the right
directory and a file.

Data handling (deleting time information and finding errors)
after this is done the same way as if you had read the DSU.

3 PROJECTS DATABASE

Open the projects database by choosing Window ->    1    Projects
database.

3.1 Adding to the projects database

Add a new project by writing it's information on top of the old
information (the old information will not disappear).

3.1.1 Fields

Project name name of the project

Project number number of the project

Project start time project's starting date
(in format yy:mm:dd)

End time project's ending date
(in format yy:mm:dd)

Project manager name of the project's manager   
not in function

Comments free format text, the length of the
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field is 255 marks and you can move
into the field only by using mouse!

Total project records  number of records in the database,
automatic

Record ordinal number of the record,
automatic          

Add the information by choosing Command -> Add. If you want to
delete old project information you can choose Command -> Delete.

3.2 Changing the projects database

If the project exist but its information has changed type
new information on top of the old information and choose Command
-> Add. You can get a new window where you are asked to confirm
the change. Accept by clicking OK.

4 DEVICES DATABASE

Open the devices database by choosing Window ->    5    Devices
database.

4.1 Adding to the devices database

Add a new device by typing it's information on top of the old
information (the old information will not disappear).

4.1.1 Fields

Serial number serial number of the device

Type   type number of the device

Name name of the device

Remarks     free format text the length of the 
field is 255 marks and you can move 
into the field only by using mouse!

Current record order number of the record, automatic

Records  number of devices in the database,
automatic

4.2 Changing the devices database

If the device exists but its information has changed type
new information on top of the old information and choose Command
-> Add. One can get a new window where you are asked to confirm
the change. Accept the change by clicking OK.



GCP/RAF/271/FIN-FM/14 (En) 5

5  SENSORS DATABASE

Open the sensors database by choosing Window ->    6    Sensors
database.

5.1 Adding to the sensors database

Add a new sensor by typing its information on top of the existing
information (the old information will not disappear).

5.1.1 Fields

Serial no serial number of the sensor.
If the sensor do not have a serial
number type as follows: D + number of
device (the device that the sensor is
connected) + channel (the channel
that the sensor is connected).
For example D27002 means that the
sensor is connected to a device,
which has a serial number 2700 and
into a channel number 2.

Version It is usually 1, but if the
calibration coefficients will change
the serial number will remain the
same and the version number will be
2.

Type type number of the sensor

Calibration place the country where the sensor was
calibrated

Date calibration date if the sensor
(in format yy:mm:dd) 

K1-K4 calibration coefficients

Formula Choose one of the three formulas by
clicking the arrow pointing
downwards.

If the calibration coefficients are K1, K1 and K2 or K2, one can
choose the first formula.

If one of the calibration coefficients is K3, choose formula two.

If one of the calibration coefficients is K4, choose formula
three.

Min minimum value of the sensor

Max maximum value of the sensor

E.g. if the sensor is measuring wind direction the minimum value
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will be 0 and maximum value 360.
Precision not in function

Sensor is connected
to a device number of the device (the device

where the sensor is connected). Obs.!
The device must be found from the
Devices database.

Channel number of the channel (where the
sensor is connected)

Measurement
type       measured variable e. g. wind speed

Dimension unit of the measured variable e. g.
m/s

Type of time series is not in function

Maintenance free format text the length of the
field is 255 marks and you can move
there only by mouse!

Record order number of the records,
automatic

No of
records number of records in the database,

automatic

Add information by choosing Command -> Add.

5.2 Changing the sensors database
If the sensor exist but its information has changed write

new information on top of the old information and choose Command
-> Add. You can get a new window where you are asked to confirm
the change. Accept by clicking OK.

6 MEASUREMENT PARAMETERS

6.1 Adding to the measurement parameters
Open the Measurement parameters -window by clicking Window -

>    7    Measurement parameters. Click New-button and fill the fields.
One can move between fields with the tabulator or the mouse.
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6.1.1 Fields

ID automatic

Place name location of the measurement device
e.g. Kigoma

Interval recording interval in seconds       
  

Map no number of the map where the
measurement point is situated

Navigational map number of the navigational map where
the measurement point is situated

Latitude latitude of the measurement point in
degrees, minutes and seconds

Longitude longitude of the measurement point in
degrees, minutes and seconds

By clicking the two arrows at the end of latitude and
longitude fields one can open a "box" where one can choose  the
unit to the latitude and longitude fields:

NO LAT northern latitude
SO LAT southern latitude

EA LON eastern longitude
WE LON western longitude

Start time measurement starting time           

End time ending time for the measurement

First sample the real first measurement time (when
the measurement device is installed
to its position)

Last sample time of the last recording (before
the measurement device is removed)

No of
measurements number of measurements in the

database, automatic

Size of
measurement data automatic

Current record the order of the record, automatic

Last update saving date, automatic

Comments    free format text, the length of the
field is 255 marks and one can move
there only by mouse!
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6.2 Saving the measurement

When all the information concerning the measurement were
added, one has to choose the right sensors. There are two
different ways to do this. Easiest way is to open Devices
database by clicking Window ->    5    Devices database and Current
sensors-window by clicking Window ->    3    Current sensors. Get the
right device by rolling the sidebar downwards. Once the right
device was found, place the mouse arrow into the background of
the window (not on top of any field) and press left mouse button.
Keep the button down and drag the arrow to the Current sensors-
window on top of channel number two. Release the button and the
sensors information will transfer to the right channels and a
checkmark will appear in front of the channels. If you don't want
to choose all the sensors you can remove the checkmark in front
of those sensors before you save the measurement.

The other way of transferring the sensors information into
the Current sensors-window is to choose them one at a time from
Sensors database. Choose the right sensor from the Sensors
database by rolling the sidebar downwards. When you have found it
place the mouse arrow into the background (not on top of any
field or grey area) and press left mouse button. Keep the button
down and drag the mouse to the Current sensors-window and on top
of that channel where the sensor is connected. release the button
and the sensors information will transfer into that line and a
checkmark will appear in front of that channel. Move similarly
all the sensors that are connected to the measurement device.

Move back to the Measurement parameters-window and choose
Command -> Add current measurement to database. Before saving the
measurement information the program will once again check the raw
data. If it finds any errors the information will not be saved.
If everything is correct you will get a message "no more errors",
accept the message by clicking OK. If you choose Command -> Save
measurement to FYS file the program will change your raw data to
real values and save it.

6.3 Changing the measurement parameters

If the measurement exists but its information has changed
write new information on top of the old information and choose
Command

-> Add current measurement to database. You can get a new window
where you are asked to confirm the change. Accept by clicking OK.

7 CURRENT SENSORS DATABASE

Open Measurement parameters -window by choosing Window ->    7   
Measurement parameters. Choose the right measurement by rolling
the sidebar. After this open the Current sensors-window by
choosing Window ->    3    Current sensors and change the window size
so that all the fields are visible. Open the Graphics-window by
choosing Window ->    8    Scalar plotting window.
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Select the Current sensors -window and choose type of
measurement (e.g. temperature). Move the mouse cursor into the
temperature row and press left button down. Keep it down and drag
the mouse cursor into the Graphics-window (Scalar plotting
window) and release the button. The program will draw the picture
automatically.

You can add six lines into the same picture. If you want a
new window move into the Graphics-window and choose New.

When you are in the Graphics-window and press the right
mouse button you can get a pop-up list where you can choose  how
the picture is plotted. If you choose Plot lines, the picture is
drawn as a line and if you choose Plot points, as points. You can
also set line width to one pixel.

7.1 Introduction

Average It can be a scalar picture or a
vector picture. Look more details
from the chapter 7.2 Average value
picture, page 9.

Component It can only be a vector picture.
Look more details from the chapter
7.3 Component picture, page 10.

Distribution It can be a scalar picture.
Look more details from the chapter
7.4 Distribution picture, page 10.

Vector It can only be a vector picture. look
more details from the chapter 7.5
Vector picture, page 11. 

Interval It can be a scalar or a vector
picture.
You define the time interval from the
pop-up list that opens when the mouse
cursor is in the time row and you
press the right mouse button.

Gauss smoothing It can be a scalar picture.
It removes "peaks".

ASCII import not yet in function

Obs.! If there are both positive and negative numbers in the time
series the 0-level line will be drawn automatically to the
picture. if the values are only either positive or negative the
0-line will not be drawn.

If the type of measurement is direction the horizontal lines of
the picture will go from 0 to 360.
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7.2 Average value picture

Open Measurement parameters -window by choosing Window ->    7   
Measurement parameters. Choose the right measurement by rolling
the sidebar. After this open the Current sensors-window by
choosing Window ->    3    Current sensors and change the window size
so that all the fields are visible. Open the Graphics-window by
choosing Window ->    8    Scalar plotting window.

Select the Current sensors-window and choose type of
measurement (e.g. conductivity). Move the mouse cursor into the
conductivity row and press left button down. Keep it down and
drag the mouse cursor to the Average-row and release the mouse
button. Text will now appear at the end of means word. Move the
cursor on top of the text and press the right mouse button. You
can get a pop-up list where you can give the average value
interval in minutes. Confirm by clicking OK.

Move the mouse cursor on top of the text and press left
mouse button. Keep it down and drag the cursor into the Graphics-
window (Scalar plotting window) and release the button. The
program will draw the picture automatically.

If you want to change the average value interval move the
cursor on top of the text and press right mouse button. Change
the interval and confirm with OK. Move the text into the
Graphics-window as told previously. The program will ask you
whether you want to add a line. if you answer yes the line will
be drawn into the same picture with previous line. But if you
answer no the line will be drawn into a separate picture.

Obs.! If you are calculating the average values of rainfall
remember that it is measured as the total rainfall between
sample. (If the recording interval is 10 minutes, the one hour
means are actually means per 10 minutes). So if you calculate 1
hour means you have to multiply means by 6. 

7.3 Component picture

Open Measurement parameters -window by choosing Window ->    7   
Measurement parameters. Choose the right measurement by rolling
the sidebar. After this open the Current sensors-window by
choosing Window ->    3    Current sensors and change the window size
so that all the fields are visible. Open the Graphics-window by
choosing Window ->    8    Scalar plotting window.

Move into the Current sensors-window and move the mouse
cursor into the Direction-row and press the left mouse button
down and keep it down. Drag the cursor into the Component-row and
release the button. You will get a pop-up  window where you are
told that the chosen series must be a vector. Confirm with OK. Do
the same thing to the Speed-row. The program will now ask you if
you want to create a vector. Answer yes and you can draw a
component picture.

The direction of the component can be defined from the pop-
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up list that opens when you move the cursor on top of the text
row and press right mouse button. When you move the text into the
Graphics-window the program will draw you a component picture.

7.4 Distribution picture

Open Measurements parameters -window by choosing Window ->    7   
Measurements parameters. Choose the right measurement by rolling
the sidebar. After this open the Current sensors-window by
choosing Window ->    3    Current sensors and change the window size
so that all the fields are visible. Open the Graphics-window by
choosing Window ->    8    Scalar plotting window.

Select the Current sensors-window and choose type of
measurement. Move the mouse cursor into the chosen row and press
left button down. Keep it down and drag the mouse cursor to the
Distribution-row and release the mouse button. Text will now
appear at the end of distribution word. Move the cursor on top of
the text and press the right mouse button. You can get a pop-up
list where you can give classes. Confirm by clicking OK.

Move the mouse cursor on top of the text and press left
mouse button down. Keep it down and drag the cursor into the
Graphics- window (Scalar plotting window) and release the button.
The program will now automatically draw the picture. Numbers on
top of the picture will tell you the percentages.     

7.5 Vector picture

Open Measurements parameters -window by choosing Window ->    7   
Measurements parameters. Choose the right measurement by rolling
the sidebar. After this open the Current sensors-window by
choosing Window ->    3    Current sensors and change the window size
so that all the fields are visible. Open the Graphics-window by
choosing Window ->    8    Scalar plotting window.

Move into the Current sensors-window and move the mouse
cursor into the Direction-row and press the left mouse button
down and keep it down. Drag the cursor into the Average-row and
release the button. Do the same thing with the Speed-row. The
program will ask you if you want to create a vector. If you
answer no you can only draw an average value picture of the
speed. If you answer yes you can draw a vector picture by
dragging the text into the Graphics- window. Also in this picture
you can give the average value interval.

The vertical axis of the vector picture is north and the
horizontal axis is east. The maximum length of the speed is from
the horizontal axis on top of the vertical axis.

By pressing the right mouse button you choose to split the
time (x) axis into two graphs. The program will do the splitting
automatically.



GCP/RAF/271/FIN-FM/14 (En) 12

8 PICTURE PRINTING

Move into that Graphics-window that you want to print.
Choose Print -> Print. The picture will be printed to the chosen
printer. Printer setup is not in function.

You can also print the picture into a table format. Choose Print
-> Convert to numeric table. You will see a pop-up window where
you can define the destination and name of the table. The table
can be printed from DOS.

9 TROUBLESHOOTING AND COMMENTS

You may have difficulties running this program if you have
only 4 MB of RAM in your computer and if you don't have a math
coprocessor. This is a problem especially when you are drawing
vector pictures. However if you have saved the all the
information nothing is lost and you can start the program again.

This program uses quite a lot of memory and you may have
difficulties running other windows-programs after you have used
Aanderaa-program. Best thing to do then is to end windows and
start it again.

We would like to have your comments about Aanderaa-program and
this manual. The program will be developed further.

We accept wishes, comments of errors in the program etc. If the
program will crash write down what you were doing and what
message did you get and send the information to us.

Comments can be send to address:

Erja Aho
Tampere Water and Environment District
P.O.Box 297
33101  TAMPERE
Finland
tel. +358-31-2420 111
fax  +358-31-2420 266

or

Anu Peltonen
Tampere Water and Environment District
P.O.Box 297
33101  TAMPERE
Finland
tel. +358-31-2420 111
fax  +358-31-2420 266

The comments about the program can be sent to us or to address:
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Toomas Kadarpik
National Board of Waters and the Environment
Hydrological Office
P.O.Box 436
00101  HELSINKI
Finland
tel. +358-0-7314 1
fax  +358-0-7314 288
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